Problem with Chrome debug extension while using Rider + Webstorm

Answered

Hello guys,

I'm currently working on a project with a nodeJS server communicating with a Unity client in c#. I use Rider as a c# IDE, and WebStorm for the server side.

The thing is, as both are opened, Rider ''takes control'' over the chrome debugging extension. How can I make that WebStorm uses it instead ? I've no point debugging my c# code for the moment, as I do most of the work on Unity itself.

I see that you can use Rider for JavaScript as well, should I completely drop WebStorm and do everything on Rider ? But then can I have a .net project at the same time as a node project ? I just bought the all product pack, I used WebStorm before but just starting with Rider, so I don't really know what I should do.

Thanks !

1 comment

Hey,

Unfortunately, that's a known issue. As a workaround, I would suggest changing a debbuger port for Rider to a different one, ex. 63345 (File -> Settings -> Build, Execution, Deployment -> Debugger -> Built-in Server -> Port), and make sure that port in extension options (right click on the Chrome extension -> Options) matches the port in WebStorm Settings (File -> Settings -> Build, Execution, Deployment -> Debugger -> Built-in Server -> Port), ex 63340. Another way is to disable Rider for Chrome extension - go to File -> Settings -> Plugins and uncheck JavaScript Debugger plugin.

0

Please sign in to leave a comment.