How to publish project


I set up a .net 4.7.2 site . When I try to set up to publish it to a ftp server . it says the project is not publishable . How do I get it so I can publish it


Hello William!

Thank you for your question!

This feature is going to be available in 2019.1.

Publish to FTP -

Publish to Folder -

In the current release, only .net core publishing is supported -




Did this get reverted in 2019.2? 

I ask because I was able to publish to a folder in 2019.1 but just upgraded to 2019.2 and am now getting this:

If so, would you please open an issue to get it fixed?




Hi Chris! 

Could you please check File | Settings | Build, Execution, Deployment | Toolset and Build | Use Ms Build version field? Do you have any VS installed on your machine? Could you please try to change from Auto detected MSBuild to another one (VS, for example)? Let me know how it helps. If something goes wrong, please, provide a screenshot with the list of the MSBuild version field. Thanks! 



Yes, I have VS 2017 on my machine as well. I switched to the auto-detected MSBuild 16 (from Rider) to MSBuild 15 (from VS) and it looks to have fixed the issue. Furthermore, I temporarily switched back to version 16 and verified that it still didn't work before switching back to 15 for the time being. I included the last bit in case it might be of help to you and/or your team.

Regardless, thank you for the quick response and spot-on advice; my issue is now resolved




But For .NET Framework is no available ? Just for Core ?


Chris, thank you for the details! This is a known issue and we'll fix it soon. 

Marian, it is also available for classic ASP.NET applications. 



Hi. I am getting same error as posted above: "current toolset does not spport...". So solution is to install Visual Studio and use its MS Build? Or am I missing something here?


Hi Marko! 

Could you please answer some questions to check what is the cause of the issue?

- Which Rider version do you use? 

- What is the type of your project: Core, .Net Framework?

- Do you have .Net5 installed?  

- Please, attach a screenshot of your File | Settings | Build, Execution, Deployment | Toolset and Build



to fix the problem just install

choco install visualstudio2022buildtools --package-parameters "--allWorkloads --includeRecommended --includeOptional --passive --locale en-US"

after, run Visual Studio Installer 

in Rider switch to this new toolchain


Please sign in to leave a comment.