Breakpoints greyed out. External storage.

This is related to issue discussed here:

https://rider-support.jetbrains.com/hc/en-us/community/posts/360000180559-Breakpoints-not-triggered?input_string=Breakpoints%20greyed%20out

However it's marked as "answered" there whereas it's not. That is why I'm starting another thread.

MacOS. Unity 2018.3.8f1. Rider 2018.3.4. Without Toolbox.

The breakpoints for some of the classes are greyed out with an error: "not found loaded method for...". This happens for newly created classes in some cases, for example when I add a new file directly ti unity.

The project is on an external SSD and I cannot move it to my main drive. I already faced this before, but at that time I fixed it with this:

https://rider-support.jetbrains.com/hc/en-us/community/posts/360000180559/comments/360000338520

Then I used Toolbox, now I'm not and the way in that post does not work for me anymore. 

Any help?

4 comments
Comment actions Permalink

I have just started getting the same issue.  I am using Rider version 2019.1.2.

Debugging was going fine.  Then when I was stopped at a breakpoint Unity crashed.  It does that more than I would like when stopped at a breakpoint.

I restarted everything, cleared all the caches, the obj dir, I even rebooted.  When I restarted Unity then Rider I can't set breakpoints.  I just get:

I am really stuck!  I need to debug and I just can't...

Currently, I am going to look for more things I might be able to reset to get this work like it was before.

0
Comment actions Permalink

Hello!

Could you please collect Rider logs?

  1. Enable Debug trace scenario (Help -> Trace scenarios)
  2. Reproduce the issue
  3. Collect the logs: Help -> Compress log...
  4. Disable debugger tracing (Help -> Trace scenarios)
  5. Share logs via https://uploads.services.jetbrains.com/ or via creating a new ticket on youtrack
0
Comment actions Permalink

In addition to the previously requested data, please send Unity crash dump to us (a screenshot), a log file, and the exact Unity version.

0
Comment actions Permalink

Your breakpoints are probably disabled.
Open Debug Tool Window (Alt+5) and uncheck "Mute Breakpoints" option on the Debugger Tab

see folloing link https://stackoverflow.com/questions/24612603/intellij-idea-breakpoint-not-being-hit-and-is-shown-greyed-out 

1

Please sign in to leave a comment.