Toolbar icon size

How can I increase the icon size of the main JetBrains Rider toolbar?

They are tiny on 1920x1200 monitor!

 

Cheers.

8 comments
Comment actions Permalink

Hello, Awit! 

Could you please tell me, what version of Rider and what  OS do you use? Do you use any special scaling? Do you have only one monitor? Look all icons small or only on the main toolbar? 

Thank you. 

0
Comment actions Permalink

I'm on Ubuntu 18.10 with XFCE desktop with default scaling. I have two 1920x1200 monitors, but typically run Rider maximised on one monitor.

I am using Rider v2019.1.1, and the icons are only 16x16 pixels.

All the the icons are too small for me, but I notice it most on the main toolbar where I have many custom buttons.

Thanks.

0
Comment actions Permalink

Awitt, 

could you please tell me your version of JDK (Help - About)? Also, are your monitors HiDPI? Could you please show me your HiDPI Info?  Also, have you tried these recommendations for XFCE? 

 

 

0
Comment actions Permalink

How big are the toolbar icons supposed to be? (in pixels)

JetBrains Rider 2019.1.1
JRE: 1.8.0_202-release-1483-b49 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.18.0-20-generic

The monitors are not HiDPI... they are bog standard, 10 year old, 24", 1920x1200...

~$ xdpyinfo | grep -B 2 resolution
screen #0:
dimensions: 3840x1200 pixels (1016x317 millimeters)
resolution: 96x96 dots per inch
0
Comment actions Permalink

Thank you for the information. Could you please provide more two screenshots: 

  • a screenshot of your workspace with Rider (with small icons) 
  • your monitor scale settings

Thank you in advance! 

0
Comment actions Permalink

Sorry for delay. I have upgraded to Rider 2019.3, but still can't figure out how to make the toolbar icons bigger.

Here is screenshot showing my Rider workspace and the window scaling (1x) from XFCE -> Settings -> Appearance...

I don't actually want to change the window scaling, but if I do, Rider seems to ignore it!

0
Comment actions Permalink

Hi Awitt, 

that's weird. I've created an issue RIDER-37380 for further investigation, please, feel free to follow it. 

Thank you! 

0
Comment actions Permalink

Hello Awitt,

Could you please try to set the VM option (Help > Edit Custom VM Options) -Dsun.java2d.uiScale.enabled=false
See also the troubleshooting guide: https://intellij-support.jetbrains.com/hc/en-us/articles/115001260010

Thank you. 

0

Please sign in to leave a comment.