How to fix, decompiler suddenly no longer working

Usually press F12 , I can see the source code,

But recently he suddenly stopped working.

I tryed 

  1. remove the user\\.Rider2019.1\config\resharper-host\DecompilerCache
  2. remove project root:\.idea
  3. Invalidate Caches and restar

But still only get the structure, not the source code.

 

Only when I reinstall again, it will return to source code.

This thing is a bit ridiculous, I am sure I have not changed any settings.

I have reinstalled it several times. Is there a way to solve this problem without reinstalling?

this image is decompiled result.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3
8 comments

I have the same problem. Any update on work arounds?

0
Hello everyone! What version of Rider do you use? Is it reproduce on 2019.2? If so, could you please collect Rider logs as described in https://rider-support.jetbrains.com/hc/en-us/articles/360001079770-How-to-collect-Rider-logs- after this happens again? Thank you in advance.
0

I use Rider 2019.2 I can reproduce it there as well.

 

I can see there is a lot of sensitive info in the log file. If I create a new support request and supply it there, will it then be private so only jetbrains can see it?

0

Yes, sure. Our developers analyze logs if you create a request! 

0

Same issue working with .Net Core 3.0 C# 8.0.  Seems fine with .Net Core 2.2 C# 7.x.

0

Hi Aleksander! 

As I said above, we need some more info. 

What version of Rider do you use?

What exactly version of .Net Core 3.0 do you use? 

Is the issue reproduces on 2019.2.2? If so, could you please collect Rider logs as described in https://rider-support.jetbrains.com/hc/en-us/articles/360001079770-How-to-collect-Rider-logs- after this happens again? You can create a support-request with them or a new youtrack issue

Thank you in advance.

0

I see the same issue in Visual Studio 2019 16.3.3, Resharper 2019.2.2 and dotPeek 2019.2.2 when working with .Net Core 3.0 C# 8.0. Similarly to what was reported above - no issues with .Net Core 2.2 C# 7.x.

0

Hi all! 

Please accept my apologies for not very accurate answer and extra questions. 

This is a known problem and here is an issue for this. Please feel free to follow and vote.

Have a good day!

0

Please sign in to leave a comment.