How to open/have winforms designer?

Completed

Hi,
i just updated Rider to 2019.2; apparently a winforms designer has been integrated in 2019.1. But i can't find it anywhere.
Double clicking the form in a newly created winforms project (any .net version, doesn't change it) doesn't open the designer as i would expect it.
I also can't find any mention of 'designer' or similar in any setting or keymap or anywhere else actually.
Did i miss something important?

15 comments
Comment actions Permalink

Hi!
The reason for the problem is in the disabled registry key rider.enable.designer.winForms.

In order to enable it, open "Find Action" dialog, type Registry. In the opened popup find (by typing) rider.enable.designer.winForms and tick the corresponding checkbox. 

 

Kind regards, 

Sofya.

1
Comment actions Permalink

Sofia Byzova,


Its Done. I have a request or suggestion for Jetbrains developer as a user perspective.

When I first installed Rider on my machine and create projects for both .Net and .Net Core web application and try to build/run, it shows an Error message that clearly says my machine don't have IIS Server installed which was very helpful to me understand. Another helpful thing was, In Settings - Build and Run - IIS, where a link that indicates for Download IIS server. So, it was easy for me to understand as a new user, what's the issue and helps me to take necessary steps.

Therefore, what I trying to say is, these sorts of indication helps me to achieve great Rider experience apart from Speed, which is very painful for using IDE like Visual Studio.

1
Comment actions Permalink

Hello!

There should be a tab "Designer" in the bottom left corner of the editor. 
If you do not see that tab, please share a screenshot of the Rider window with an opened form, your csproj file, and collected logs. Having a sample solution would be perfect.

Also, the following blog post about developing Windows Forms applications in Rider might be useful.

Kind regards,

Sofya.

0
Comment actions Permalink

Hi,
thanks for the fast answer. Here's a screenshot of a fresh project.
I attached the logs to a request (#2211646) as mentioned on the page you linked.

0
Comment actions Permalink

Hi,

I had this similar issue however, now its solved. thanks to Sofya.
On the other hand, I have another one. When I try to open any WinForms Application via .Net Core, Its showing error that I don't understand what Framework it is showing about !!

0
Comment actions Permalink

Hi @Md. Akter Hossain,

Thank you for your message.

Could you please clarify what Framework version do you have installed? Also, please try creating this project via the command line:

dotnet new winforms -f netcoreapp3.1

If it does not work (it definitely does not as Rider uses this functionality), please install a fresh dotnet core version 3.1.202 and check if the issue persists.

There was a bug which is fixed in the latest .NET Core build: https://github.com/dotnet/winforms/issues/2981.

Please let me know about the results.

 

Sofia.

0
Comment actions Permalink

Hi Sofia Byzova,

Thanks for the replay.

Yes, your given command line isn't work first-time. So, I have investigate my installed files, where I notice, when I installed .NET Core framework via Rider's Settings Environment, it doesn't install the .NET Core SDK, it actually installed only .NET Core and ASP.NET Core Runtime packages Not Desktop Runtime. Therefore, I have installed manually .NET Core SDK,3.1.202 version.

After that, your given command--line shows this error message: "Error: Invalid parameter(s)", so, I tried, this command (dotnet new winforms) that suggested at the end of previous error command: and it's worked fine. However, On Rider, its still showing the Same Error Message of missing Target Framework.

0
Comment actions Permalink

Hi @Md. Akter Hossain,

Rider does install the full .NET Core SDK (including runtime).

There was a mistake in the command in my previous message. I've fixed it now. Of course, you're right and the command "dotnet new winforms -f netcoreapp3.1" should be there.

I can reproduce this behavior if .NET Core 3.1.1xx is run. But I can create a template project in terminal using "dotnet new winforms -f netcoreapp3.1" if .NET Core 3.1.2xx is working. Could you please clarify if you restarted the terminal session and Rider after the new Core version installed?

Please run the command "dotnet --version" in Rider terminal and in the external Windows console (ex. cmd) and let me know about the result.

 

Sofia.

0
Comment actions Permalink

Yes, Its working in Both side but still same on Rider's interface. @Sofia Byzova

 

0
Comment actions Permalink

@Md. Akter Hossain, 

Could you please share a screenshot of the settings page "File | Settings | Build, Execution, Deployment | Toolset and Build"?

 

Sofia.

0
Comment actions Permalink

Sofia Byzova

= Inside MSBuild Version Combo Box-

 

0
Comment actions Permalink

Thank you,

Could you please try to set "16 - C:\Program Files\dotnet\sdk\3.1.202\MSBuild.dll" (the third list item) and check if the issue persists?

 

0
Comment actions Permalink

Sofia Byzova,

                 Nope!! Same as before.

0
Comment actions Permalink

Hi Md. Akter Hossain,

There is a bug and I've filed an issue: https://youtrack.jetbrains.com/issue/RIDER-44879.

Could you please collect all logs and attach them to the issue? 

To collect logs:

1) Open logs folder via "Help | Diagnostic Tools | Show Logs in Explorer" or "Help | Show Logs in Explorer"

2) Close Rider

3) Clear the log folder

4) Reproduce the issue: Open Rider, press "New Solution", and select .NET Core Winforms.

5) Close Rider and compress the whole log folder

6) attach the archive to the issue https://youtrack.jetbrains.com/issue/RIDER-44879.

Our developer will investigate it as soon as possible.

Thank you for your patience.

 

Kind regards,

Sofia

0
Comment actions Permalink

Thank you for the logs and your feedback.

We are doing our best to improve UX in Rider. And users' feedback is extremely important for us. So please, feel welcome to contact us if you have any suggestions or questions about Rider.

 

Sofia.

0

Please sign in to leave a comment.