Rider 2019.2 (Linux) "Syncing projects..." never stops, won't load project files.

Completed

Hello,

    Rider 2019.2 downloaded and updated via toolbox, I went to open a small project I had opened and built the other day when I noticed that Rider had updated. When the IDE loaded, I thought it was taking an awful long time. I let it sit for 30 minutes but it just sits there saying "Syncing projects..." at the bottom and spinning. The project explorer just has the project name and "loading..." next to it, and for the projects immediate child. I completely disabled syncing, both in the setting in the bottom corner as well as disabling the sync plugin, but each time I close and reopen it does the same thing just sitting there syncing and running my CPU the whole time.

 

I reinstalled 2019.1.3 and opened the same project in that and it was fine. So for the time being 2019.2 seems unusable for me, unfortunately.

Thanks,

-MH

11 comments
Comment actions Permalink

Hello!

Thank you for reporting this problem!

Could you please, share Rider logs (Help | Compress Logs and Show in ...) and attach the archive to the corresponding issue on youtrack?


Kind regards, 

Sofya

0
Comment actions Permalink

No worries, I have attached them to the issue.

0
Comment actions Permalink

Hello!
Could you please try setting the used MSBuild to an `Auto detected` value via `File| Settings | Build, Execution, Deployment | Toolset and Build` -> `Used MSBuild version`. Does the problem persist?

1
Comment actions Permalink

Hello Kivan,

Thank you for filing the issue. We will take a look.

 

Kind regards,

Sofya.

0
Comment actions Permalink

Same issue on windows

with rider 2019.3.4

 

0
Comment actions Permalink

Hi Robert,

Did you open a Unity project in Rider, and then IDE hangs on syncing project, right?

Could you please reproduce the issue once again, then call the action "Help | Compress Logs and Show in Explorer". A Rider logs folder will be opened, and a newly created archive will be focused.

Please, create a new support request here: https://rider-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=97145, and attach the logs to it.

I'd also suggest trying Rider 2020.1.2 and check if the issue persists there.

Thank you in advance.

 

Sofia.

0
Comment actions Permalink

Same problem here. I did invalidate and sync.

My project is unity (2019.2.17f1) + Oculus Quest.

JetBrains Rider 2020.1.3
Build #RD-201.7846.1, built on May 15, 2020
Runtime version: 11.0.7+10-b765.53 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
.NET Framework 4.0.30319.42000
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1450M
Cores: 12
Registry: debugger.new.debug.tool.window.view=true, ide.tree.horizontal.default.autoscrolling=false, performance.watcher.sampling.interval.ms=200, ide.tooltip.showAllSeverities=true, show.diff.preview.as.editor.tab=true, ide.borderless.title.product=false, ide.title.debug=true, performance.watcher.unresponsive.interval.ms=1000, ide.tooltip.initialDelay.highlighter=0, search.everywhere.settings=true, show.diff.preview.as.editor.tab.with.single.click=true, parameter.info.max.visible.rows=10, ide.win.file.chooser.native=true, vcs.log.show.diff.preview.as.editor.tab=true, ide.borderless.title.debug=true, ide.borderless.title.project.path=false, search.everywhere.pattern.checking=false, ide.tooltip.initialDelay=0, ide.borderless.title.classpath=false, ide.require.transaction.for.model.changes=false
Non-Bundled Plugins: com.microsoft.vso.idea, org.intellij.plugins.markdown, com.godwin.json.parser, com.protobuf.free.gen.plugin.GenProtobuf, io.protostuff.protostuff-jetbrains-plugin, org.antlr.intellij.plugin, com.jetbrains.rider.android, com.intellij.resharper.azure

0
Comment actions Permalink

Hi Richard Lalancette,

 

If you encounter this issue again, please, collect the logs via Help -> Collect Logs right after you encounter this issue and send them to us by creating a new support request or by creating a new issue on the tracker.

 

It would help if you could include the Unity version you are using as well.

0
Comment actions Permalink

Same issue today, Rider 2020.2.2 on Catalina. Eventually, after some 7 minutes, it finished. But it was no Unity, only a quite simple F# 4.7 code targetting .net core 3.1.

 

0
Comment actions Permalink

Hi Wwinogrodzki,

 

If this issue persists on your F# projects, please collect the logs using Help->Collect Logs, and a few thread dumps by calling Help -> Diagnostic tools -> Collect Backend thread dumps action a few times, while the synchronization is still running. Then, you can attach this data to a new issue on the tracker.

 

Thank you in advance.

 

0

Please sign in to leave a comment.