xamarin.ios development with rider almost impossible

I tried to open an xamarin-solution in Rider2019.2.(Windows) . The Xamarin-Mac-Agent popped  up and i tried to enter the ip-address of the mac. To say it short: The Connection to the mac (including the credentials) took almost 5 minutes. Even now after a buld i see since 3 minutes an empty "Select Deployment target" with the status messages"Fetching list of devices" . In earlier versions i saw at least quickly the Simulators.

Maybe its important to say, that i dont changed the settings.

Is there anyway to speed up the development? 

(Except of course using Visual Studio ;) )

 

BR

Steffen

2 comments
Comment actions Permalink

This problem is show stopping. It happens with Rider mac also. Please fix it as soon as possible

0
Comment actions Permalink

Hi,
There is an issue on youtrack: https://youtrack.jetbrains.com/issue/RIDER-31609, but it depends on a fix for another ticket: https://youtrack.jetbrains.com/issue/RIDER-31079. Please, watch those issues for updates.

 

Sofia.

0

Please sign in to leave a comment.