How to remove live templates from the completion list?

Answered

When I write “try”, the template appears first in the completion list, not the keyword. This is terribly annoying. How to remove all live templates from the completion list, but without deleting them?

6 comments
Comment actions Permalink
Hi Dmitry! You can remove live template on the `File | Settings | Editor | Live Templates | C#` tab. Please note that by default it affects only to an opened solution.
0
Comment actions Permalink

I don’t see the checkbox "hide templates from the completion list" there.

Do I need to customize this for each of the 100+ templates? :)

0
Comment actions Permalink

There is no such checkbox yet, but please, upvote these issues: RIDER-31262, RIDER-31261

Now it is possible only to remove templates one by one. You can remove only those templates you don't like.

Actually, there is a workaround.

- go to `File > Settings > Manage layers`

- in the context menu of solution personal layer choose "Open containing folder"

- open corresponding "*.sln.DotSettings.user" file in a text editor

- add this line: <s:Boolean x:Key="/Default/CodeEditing/Intellisense/CodeCompletion/ReplaceKeywordsWithTemplates/@EntryValue">False</s:Boolean> 

- restart Rider.

Enjoy :)

1
Comment actions Permalink

Unfortunately, ReplaceKeywordsWithTemplates doesn't help to fix the behavior of the "new" template. :(

0
Comment actions Permalink

Hi Dmitry, 

I suppose this should be Postfix template. Set the `File | Settings | Editor | General | Postfix Completion => Enable postfix completion` checkbox off to disable all of them. 

1

Please sign in to leave a comment.