Missing custom color scheme

Had to roll back to version 2019.1.3 after recently updating to version 2019.2.1 after all Editable Variables of Live Templates weren't editable on Macos. Whilst using version 2019.1.3 prior to the latest update I had spent hours perfecting my color scheme and saving it under Resharper Dark copy. Please help. Where can I find my lost color scheme configuration file because I am not looking forward to spending wasted time re-establishing all my changes only to find them gone again after the next, HOPEFULLY successful update.

2 comments
Comment actions Permalink

Hello Mark,

Did you update via "Help -> Check for updates" or Toolbox? From 2019.2 to 2019.2.1? Do you have sync via IDE Settings Sync plugin enabled?

You can find the settings from the previous Rider version in the directory "/Users/<user>⁩/Library⁩/⁨Preferences⁩/Rider2019.1". As a workaround, you can export your color scheme from 2019.1.3 via the action in settings "JetBrains Rider | Preferences | Editor | Color Scheme" https://www.jetbrains.com/help/rider/Settings_Colors_and_Fonts.html?keymap=mac_os_x_10.5_

Then import this color scheme into Rider 2019.2.

Please, let me know if you were able to use your color scheme in Rider 2019.2.

As for the problem with live templates, could you please share a gif, or steps to reproduce? I was not able to catch the problem.

It seems that the following issue describes a similar problem. You can attach requested information to it.

 

 

0
Comment actions Permalink

Hello again,

could you please share your config folder ("/Users/<user>⁩/Library⁩/⁨Preferences⁩/Rider2019.1") with us via the https://uploads.services.jetbrains.com/ (let me know the exact name of the uploaded file)?

0

Please sign in to leave a comment.