Cannot attach Unity debugger

Answered

I literally don't see an option to attach Unity in the Rider. It's installed and the 'Editor attaching' option is checked in Unity preferences. I use Unity 2019.2.5 and Rider 2019.2. Please advice

8 comments
Comment actions Permalink

There is no plugin for Rider in Unity automatically installed as described in the tutorial videos. However Rider Editor package is installed ver. 1.1.0

0
Comment actions Permalink

Hello Alex,

Starting from Unity editor 2019.2 the plugin does not affect the work with debugger. Could you please clarify a bit how are you trying to attach to debugger? In normal occasion you should be able to see the following option:

What do you see in that pane?

0
Comment actions Permalink

I managed to resolve the issue. The problem was that I had previously installed rider 2018 before and the settings were imported from it during installation, which didn't include unity support.

0
Comment actions Permalink

Thank you for keeping me posted, I am glad to hear the issue was resolved.

0
Comment actions Permalink

I am still having this issue - the run->attach to unity process only contains an entry for the unity editor. I recently upgraded to 2019.2.3 - before this it was working fine.

I managed to get it to work just once by disabling and re-enabling the unity plugin - this no longer works.

0
Comment actions Permalink

UPDATE - I just hit the "hammer" icon (Build solution) and afterwards it was then possible to find the player in the list. The player was running in the background

0
Comment actions Permalink

Unfortunately this is not repeatable - I will have to revert to Visual Studio for debugging unfortunately

0

Please sign in to leave a comment.