Why am I seeing warnings about dotnet core compatability when not in a dotnet core project?

Completed
 Microsoft.AspNetCore.App.targets(14, 5): This version of Microsoft.AspNetCore.App is only compatible with the netcoreapp2.2 target framework. Please target netcoreapp2.2 or choose a version of Microsoft.AspNetCore.App compatible with .

 

I'm not sure why I am seeing this error message in Rider when the branch of the project I am working on is targeting dotnet framework. A different branch targets dotnet core and I would perhaps expect to see it then. However, I don't see this error message when opening the project in Visual Studio. Opening in VS also allows me to build the project etc. where as Rider won't let me build or restore properly.

 

This recently started happening when I installed dotnet core 3.0.

4 comments
Comment actions Permalink

Turns out that I had some SDKs left installed from VS2019. Removing those made the error go away.

0
Comment actions Permalink

So that worked for working on a dotnet framework project but now that I'm back on a dotnetcore 3.0 project, it won't build despite having the 3.0 sdk installed.

 

Is this only going to work if I have VS2019 installed?

0
Comment actions Permalink

Hi Nathan! 

I suppose we could continue this conversation in your private support request. 

Have a good day! 

0
Comment actions Permalink

Hi, sorry for doubling up on requests. After my initial fix didn't appear to work I figured a support ticket might be better.

0

Please sign in to leave a comment.