Trusing the dev cert on Linux (RHEL)

So I've run 'dotnet dev-certs https --clean', followed by 'dotnet dev-certs https', which says the certificate was generated successfully (apparently the --trust flag does not exist [yet] on Linux). Trying to manually place the file in /etc/pki/ca-trust/source/anchors and running `update-ca-trust enable/extract` doesn't seem to fix the issue. I still get the following when I try to run my app:


System.InvalidOperationException: Unable to configure HTTPS endpoint. No server certificate was specified, and the default developer certificate could not be found.
To generate a developer certificate run 'dotnet dev-certs https'. To trust the certificate (Windows and macOS only) run 'dotnet dev-certs https --trust'.


Any suggestions?

1 comment
Comment actions Permalink

Hello Yousef,

We have tested it in our lab, and it worked as expected. So far it does not look like the issue is Rider-specific, could you please contact MS for check from their side?


Please sign in to leave a comment.