Multitarget version

Answered

Hello,

I have multitarget .net core project. In my .csproj i specified target frameworks as below:

<TargetFrameworks>netstandard2.0;net452</TargetFrameworks>

even if 'netstarndard2.0' target framework is first in order, Rider applies .NETFramework 4.5.2 as default in code editor. I have to change it every time I run Rider.

Is there any possibility to set other default?

2 comments
Comment actions Permalink

Hello,

At the current moment, there is no such option, I have created a corresponding request on our bug tracker: RIDER-38772. We would appreciate if you would upvote the issue and Watch for monitoring the status. 

 
0
Comment actions Permalink

Damn this took me almost an hour to find that setting! I definitely think there should be some documentation added for that setting in the status bar. (In VS it is in the top left, couldn't find it, started searching through all the various options, following by searching rider docs, only to later search in bing to find this article!)

0

Please sign in to leave a comment.