Scrollbar thumb color won't change

Completed

When working on legacy .cs files, the scrollbar is often a rainbow of Code Analysis marks - so the default, low opacity grey scrollbar thumb is virtually invisible.

So I changed this setting:

JetBrains Rider 2019.3.1 → File → Settings → Editor → Color Scheme → Vertical Scrollbar → Thumb → Background → FF00FF

However even after restart of Rider it doesn't change.

Not sure if it's relevant, but the above settings dialog doesn't allow the Foreground colour to change

What am I missing?

Thanks.

1 comment
Comment actions Permalink

I found this workaround on an IntelliJ IDEA YouTrack issue: Add editor scrollbar configuration on Windows and Linux

Arseniy Nisnevich commented 1 Sep 2019 14:23
Workaround:
  1. Press Help | Edit Custom Properties... (if a dialog appears, press "Create")
  2. "idea.properties" file will open. Add editor.transparent.scrollbar=false to a new line
  3. Restart IDE

Will the above editor.transparent.scrollbar setting be fixed in Rider? I can't find a YouTrack issue for it.

Unfortunately the "Color Scheme → Vertical Scrollbar" setting also changes the Horizontal scrollbar color, so now I have a huge magenta bar stretching over half the screen when Rider is maximised...

I just raised RIDER-37963 for this.

0

Please sign in to leave a comment.