How to configure the behaviour of auto add a semicolons after an auto-completion?

Answered

For example :

I have va and vb as Vector3.

When trying to give a value to va. If choose Vetor3.back by tab from auto completion, rider will add a semicolon at the end of line.

But if I choose vb by tab from auto completion, rider will NOT add a semicolon at the end of line.

This different behaviour of same funciton is very annoying. Where can I configure this function? Like turn of auto add semicolon after auto completion.

1 comment
Comment actions Permalink

Hello,

 

thank you for contacting us.

There's a different behavior, cause in one case you are selecting an object which can be also provided with some properties or methods, in another case you are selecting completed expression, so the semicolon is added automatically.

There's no way to disable semicolons, but you can try using Complete Statement feature for completing cases with objects to get consistent behavior.

Please let me know if you have any more questions.

Thank you.

0

Please sign in to leave a comment.