Not able to step-into async methods

Just decided to give Rider a try and right of the start I experienced some strange behavior and I'm not sure how to fix it. I tried to step-into an async method (F11) and it doesn't work, meaning I never get to go inside the async method (GetRequestUserAsync)

I got the "Smart Step into" dialog. If I select my method, it just steps out like if I had used F10 instead and never goes inside the async method.
Sometimes it does go inside the ValueTask.GetAwaiter code from the framework.

Am I missing something here or is this a bug?

JetBrains Rider 2020.1.0
Build #RD-201.6668.197, built on April 15, 2020


2 comments
Comment actions Permalink

Hi! Thank's for contacting us. 

I suppose you faced a known issue in Smart Step Into for async methods. As a workaround, please disable "Always do smart step into" option in `File | Settings | Build, Execution, Deployment | Debugger | Stepping`. Please let me know if this help. 

2
Comment actions Permalink

Hi Alexandra!

That worked, thank you! 

0

Please sign in to leave a comment.