Rider For Unreal Debugging

Completed

Starting to check out Rider For Unreal.

When paused on a Debug Breakpoint in my game code, any engine functions in the Call Stack are displayed as assembly?

 

Is there any way to show the engine call stack in cpp?  After all, the engine source and symbols are available?

19 comments
Comment actions Permalink
Unfortunately, it is a known issue related to auto-detecting source maps.
To workaround this you can try to do next steps:
  1. create a file named .lldbinit in your home  user directory (on Windows it is C:\Users\<your user name>)
  2. write there a command
    settings set target.source-map  <unreal engine path on build server> <local sources path> 
    .For example, for prebuilt engine from Launcher it looks something like that:
    settings set target.source-map d:\build\++ue4\sync D:\Games\UE_4.23
(Note: casing matters!)
1
Comment actions Permalink

Thanks Julia -  Still having issues....

How do I validate the <unreal engine path on build server>?

I tried using:

d:\build\++ue4\sync

for 4.24 Launcher, but its still not working...

1)  created .lldbinit in home dir

2)  settings set target.source-map d:\build\++ue4\sync H:\Epic Games\UE_4.24

3)  restarted Rider.  It did seem to index the source files on start.  But the call stack is still assembly.

 

Thanks again for your help

0
Comment actions Permalink

Please try to quote the source path. You can lookup the actual path in PDB files for engine dll-s. Just open it in some text viewer and look for strings containing engine source filenames.

1
Comment actions Permalink

Thanks Julia!  It works now!!  It was the missing quotes  :-)

1
Comment actions Permalink

Note: in UE 4.25 Epic Games changed location on their build server and used compiler from vs2019 instead of vs2017.

So mapping should be changed to be like this:

settings set target.source-map "D:\Build\++UE4+Licensee\Sync" "C:\Program Files\Epic Games\UE_4.25"
0
Comment actions Permalink

Hey!

I experience the same on 2020.1.3. Is this planned to be resolved in a future update?

(The workaround works until then, thanks for sharing!)

0
Comment actions Permalink

I've applied the steps and it works for engine code, now I'm trying to achieve the same result with code plugins I've bought in the Marketplace and installed to my engine. It seems that the source map for code plugins is "D:\Build\++Portal+Promotion\Sync". How would I add this folder to the lldbinit file?

0
Comment actions Permalink

Since update 2020.1.3 you can try to write mapping using special wildcard syntax without mentioning original source path locations

settings set target.source-map * "C:\Program Files\Epic Games\UE_4.25"

and then debugger should auto-detect all missing mappings and it work for both engine and plugins.

And of course we will make setup of such mappings transparent and automatic in some future, but it's not implemented yet.

1
Comment actions Permalink

Debugger is once again opening to assembly after the latest update today

0
Comment actions Permalink

The update does not include the fix, please use the mentioned workaround.

0
Comment actions Permalink

Hey, my engine is on another drive and it doesn't seem to work. This is what I have inside the file:

settings set target.source-map * "D:\Epic Games\UE_4.23"
0
Comment actions Permalink

Hi! Are you using the latest version of Rider for Unreal Engine?

0
Comment actions Permalink

Hello, yes, I'm using 2020.2

I reinstalled unreal into the drive C:/ and it's working. Rider is also installed on C, so maybe it's something related to it?

0
Comment actions Permalink

The drive selection should not affect mapping detection, and we cannot reproduce the issue. Anyway, I glad to hear it works after reinstalling.

0
Comment actions Permalink

Any progress on fixing this?

0
Comment actions Permalink

Unfortunately, nothing to share yet; we'll announce when the fix is available.
Also, we have a ticket in YouTrack: https://youtrack.jetbrains.com/issue/RIDER-48733, you can follow it to get notifications about its status updates.

0
Comment actions Permalink

I'm having the same issue as Luiz had.

 

My game project is on C:\, while Rider is installed on D:\ , and when debugging I can't debug the engine code.

It works for projects that are on D:\

0
Comment actions Permalink

My engine is also on another drive, but my projects are there too. Works for me with latest Rider (2020.3.1) and UE4 (4.26). My file

settings set target.source-map * "M:\UE_4.26\Engine"

 

0
Comment actions Permalink

Hello! This is fixed in the last Rider for Unreal Engine 2020.3.3, build #RDCPPP-203.5981.163

0

Please sign in to leave a comment.