How can I disable auto-insert of double quotes in Rider 2020.1.0?

Whenever I type a double quote in Rider, no matter what key I then press, Rider automatically inserts another double quote.

So when I for instance type "123"; the result is:

 ""23""


I really dont want help typing quotes. How can I disable this behaviour? Its killing my speed.
I tried ticking off "Auto-insert pair brackets, parentheses and quotes" in Settings -> Editor -> General -> Typing Assistance, but it didnt help.

Thanks,
Rune

2 comments
Comment actions Permalink

Hello, could you please collect all Rider .DotSettings files:

- *Personal layer*:.DotSettings.user file near your sln (if any)
- *Team-shared layer*:.DotSettings file near your sln (if any)
- *Global settings layer*: Use "Help -> Browse Special Files and Folders -> R# Global Settings" to locate GlobalSettingsStorage.DotSettings file

And attach them with a new issue on our tracker, so we could check out what exactly causes such behavior in your case. Thank you in advance!

0
Comment actions Permalink

Hi,

Done: https://youtrack.jetbrains.com/issue/RIDER-44514

Help -> Browse Special Files and Folders does not exist on my installed version of Rider, but I found GlobalSettingsStorage.DotSettings in ~/Library/Application Support/JetBrains/Rider2020.1/resharper-host. Hope this is the right file.

Thanks,

Rune

0

Please sign in to leave a comment.