Unable to start debugging session: Failed to detect dbgshim directory

I have an education version of Rider installed on an Arch Linux platform. I am trying to debug a project and have received this error message: "Unable to start debug session: Failed to detect dbgshim directory./usr/share/rider/lib/ReSharperHost/linux-x64/dotnet/dotnet exec /usr/share/rider/lib/ReSharperHost/JetBrains.Debugger.Worker.exe --mode=client --frontend-port=36321 --plugins=/usr/share/rider/plugins/rider-unity/dotnetDebuggerWorker"

The solution builds and runs/debugs in Visual Studio. Could you please advise some guidance....

dotnet --info
.NET Core SDK (reflecting any global.json):
Version: 3.1.201
Commit: b1768b4ae7

Runtime Environment:
OS Name: arch
OS Version:
OS Platform: Linux
RID: arch-x64
Base Path: /usr/share/dotnet/sdk/3.1.201/

Host (useful for support):
Version: 3.1.3
Commit: ed88943d24

.NET Core SDKs installed:
3.1.201 [/usr/share/dotnet/sdk]

.NET Core runtimes installed:
Microsoft.NETCore.App 3.1.3 [/usr/share/dotnet/shared/Microsoft.NETCore.App]

11 comments
Comment actions Permalink

Hi Tim,

I had the same issue, also on Arch Linux.

Error message is misleading, try running this for more details.

dotnet run

In my case, I had to install aspnet runtime to fix this.

pacman -S aspnet-runtime

 

Cheers

1
Comment actions Permalink

Thanks for the comment. Unfortunately this hasnt worked. I have the latest sdk installed so the runtime was included. I reinstalled it but I'm still getting the same error. Great to know there are people out there that try to help.

This ticket has been sitting here for nearly 3 weeks and has had no attention from the support people at Jetbrains.

0
Comment actions Permalink

No worries, I know how annoying these issues can be.

Did you get any new info after "dotnet run"?

0
Comment actions Permalink

Experiencing the same issue on Ubuntu 20.04. I have the sdk installed, and have tried multiple configs to get this to work with no success. 

0
Comment actions Permalink

Jack J Barger

First of all, is Rider able to run your application without debugging it?

Also, may I ask you to collect the logs again with the Debugger and  Run trace scenario turned on?

  1. Navigate to Help | Diagnostic tools | Choose Trace Scenarios and enable Debugger and  Run Trace scenarios;
  2. Restart Rider;
  3. Start a debugger session to get the dbgshim directory not found message;
  4. Try to run your application;
  5. Collect the full log bundle via Help | Collect Logs;
  6. Disable the trace scenarios;

Please attach the log bundle to a new support request.

Thank you in advance!

0
Comment actions Permalink

We've reproduced the problem, and, hopefully, we'll be able to fix it in Rider 2020.2. Please watch the corresponding issue on YouTrack for updates: https://youtrack.jetbrains.com/issue/RIDER-45519

1
Comment actions Permalink

Thanks Julia and let me know if you still would like the debug logs. I ended up using another machine to finish the project I had been working on, but am happy to reproduce the error if needed.

0
Comment actions Permalink

In my case, I had to right click on the project -> properties and select "target framework" the one that you have installed on your PC. I hope this helps.

3
Comment actions Permalink

I'm still getting this problem on 2020.3

How much longer for a fix?

Unable to start debug session: Failed to detect dbgshim directory."C:\Program Files\JetBrains\JetBrains Rider 2020.3.3\lib\ReSharperHost\JetBrains.Debugger.Worker64c.exe" --mode=client --frontend-port=52715 "--plugins=C:\Program Files\JetBrains\JetBrains Rider 2020.3.3\plugins\rider-unity\dotnetDebuggerWorker"

 

All I do to reproduce is click "Debug" on an existing netcoreapp3.1 project

 

0
Comment actions Permalink

Rsryanstephen

A bunch of problems related to detecting dbgshim directory are fixed in Rider 2021.1. Could you please try the latest EAP build and check if debugging works for you?

0
Comment actions Permalink

Thanks Julia all is well 

0

Please sign in to leave a comment.