Rider doesnt index packagecaches in Unity, how do i add these to the structure window?


Im using some packages from Unity in the packages folder, Rider wont index them (list them in structure) because it says its outside of the project.  How do i add these to Rider's structure/indexing without moving the files in the project?




Simply dragging the folder from packages to Assets worked.


Hi Chris, 

Glad to hear that!
You are welcome to contact us in case of any questions or problems.
Have a nice day :)



Hello, I would like to ask if there is a solution to this issue without moving the source files of the Unity package into the Assets area of my project. I would like to leave the source files for the package to be maintained and updated, etc by the package manager of Unity. However, I would also like to have the Structure panel, etc update and display accurate information when viewing source in these packages.

Thank you have a nice day.


Hi Bvpeck

Try right-click on desired file/folder and choose `Tools | Start index`. I hope this helps! 


In my case, I was not shown the structure of a class from an MRTK tarball package (.tgz) in Unity.

Ticking Local taball in External Tools -> "Generate .csproj files for:", then clicking Regenerate project files, and waiting for Rider to synchronize the project solved the issue.





Please sign in to leave a comment.