The "Modifiers order" setting does not work

Answered

The "Modifiers order" setting does not work. There is no suggestions, and Reformatting won't reorder them.

I suspect that the "File Layout" may have hidden this setting. I rewrote the sort of fields setting, and I was able to reorder them as I intended.

3 comments
Comment actions Permalink

Environment:

- JetBrains Rider 2020.1.3 Build #RD-201.7846.1, built on May 16, 2020
- Windows 10 Pro 2004

0
Comment actions Permalink

Gigacee hi! Thank you for your question.

"Modifiers order" setting configures a different thing; this affects the order of modifiers for the same code object, for example, “protected abstract int Foo” or “abstract protected int Foo”, and no more. So you did everything right, you need to use File Layout for sorting lines. Please let me know you have any other questions, have a great day! =)

0
Comment actions Permalink

I fully understand, Thank you!

0

Please sign in to leave a comment.