Rider stopped launching


So my Rider suddenly stopped launching this morning. Launching as admin doesn't help and latest logs for rider are from three days ago. Can anybody help me?

Official comment

Hi guys!

Unfortunately, you faced a known issue: RIDER-47292, our team is working on the fix.

Please, install Rider 2020.1.4 using the full installer or with ToolBox.

We apologize for this.

Same for me 😢

Also, just updated Data Grip and that is now broken as well.

Win 10, Version 2004 (OS Build 19041.329)
JetBrains Rider 2020.1.3DataGrip 2020.1.4



Reinstalling helped, thanks!


I am now experiencing this exact issue in Rider 2022.2.3 on Windows 10 Enterprise. I installed Rider two days ago, and it worked great for a couple days, but now it won't launch at all. As with the original post, launching as administrator does not help.

The last thing I did before this issue happened was to open two different projects in Unity. When I opened a .cs file from the second project, it opened into the same window as the first solution rather than opening a second Rider window/instance (as it did a few months ago when I was using Rider frequently). Perhaps this has something to do with the issue?  

I'm going to uninstall and reinstall in the hopes that helps. For posterity, here is a link to the logs before I reinstalled:


Edition    Windows 10 Enterprise
Version    21H2
Installed on    ‎2/‎11/‎2022
OS build    19044.2006
Experience    Windows Feature Experience Pack 120.2212.4180.0

Processor    AMD Ryzen 9 5900HX with Radeon Graphics           3.30 GHz
Installed RAM    16.0 GB (15.4 GB usable)
System type    64-bit operating system, x64-based processor


Update: When I tried to uninstall Rider, it claimed that it was already running!

Yes, it looks like Rider has *many* background processes running, even though nothing is showing up on my taskbar, and I have no ability to quit these processes with Ctrl-Shift-Esc.

UPDATE: Manually closing all of those tasks in the task manage allowed Rider to launch again. As far as I know, Rider did not crash, but somehow it is not clearing out something in the background.


Hello Gameprof,

Thank you for the update. 

Have uninstalling and reinstalling helped? 
If the issue persists, please collect a crash dump using these instructions: How to collect a dump on a specific crashed or hanged process.  Attach it  either to our storage( uploads.jetbrains.com) and provide me the ID  or create a separate issue in our YouTrack

Looking forward to hearing from you soon.


Please sign in to leave a comment.