Changing numpad comma for dot

I'm using macOS 10.15.5 with a spanish keyboard in which the numpad has a comma instead of a dot. I was able to replace the behaviour in the while system, including Rider.

However, earlier today the behaviour was reversed only in Rider. When I press the numpad comma key (which should remap into a dot because of my system settings), Rider prints a comma instead of a dot.

This behaviour starting happening out of the blue. Any ideas on why this might be happening or how to reverse the behaviour?

JetBrains Rider 2020.1.4
Build #RD-201.8538.1, built on July 3, 2020

3 comments
Comment actions Permalink

Hello,

Could you please clarify how you did redefine "," with "." in your environment? I tried to reproduce this with "System Preferences > Language & Region > Advanced" but "." is not inserted nor in Rider nor in any other application.

Thank you in advance.

Sofia

0
Comment actions Permalink

I modified the file DefaultKeyBindings.dict file under Library/KeyBindings and added this line:
"#," = ("insertText:", ".");

For last couple days, however, Rider has been ignoring this setting

0
Comment actions Permalink

Hello Antonio,

Do I understand it right that all other applications use "." instead of "," on the Spanish keyboard?

Could you please share the entire content of the file DefaultKeyBindings.dict?

0

Please sign in to leave a comment.