How to make "This Computer" layer apply to "Settings for New Projects" and my currently opened project? (Multiple issues with settings)

I have a frustrating problems with the settings and don't know how to solve it. I changed some settings in the "This Computer" layer, for example:

Then I make sure the inspections and code style are copied into the "Team-Shared" layer, and that there are no settings set in the "Personal" layer at all. As far as I understand, this should apply in the project because the "This Computer" and "Team-Shared" layers are identical, and the "Personal" layer is literally empty (there is no .User file in the project directory), however this happens:

After spending a while trying to figure this out, I found out that if I open "Settings for New Projects", for some reason none of the settings were applied there??

And if I change the settings here, they immediately apply in the project.

What??

Why do "Settings for New Projects" apply to my existing projects, while at the same time settings from "This Computer" and "Team-Shared" layers are completely ignored? This doesn't make any sense to me. How do I force "This Computer" layer to overwrite whatever settings are stuck in "Settings for New Projects"?

4 comments
Comment actions Permalink

I ended up re-importing all settings and changing the inspection above without having any open projects, that seems to have fixed it. However, I still have a problem with "Problematic whitespace" inspection which is complaining that a file is using Tabs. These are my settings:

This seems okay, however...

In the "Personal" layer, code style is set to use spaces instead. The title says "sln.DotSettings.User" file in the solution folder, however there is no such file in the folder - I had reset the layer, deleted the file, restarted Rider, there is no "Personal" layer file! Why is Rider showing different settings for the "Personal" layer when I completely removed it? It should be using the team-shared layer, shouldn't it?

0
Comment actions Permalink

To add additional information - the Tab indent setting works correctly if I use the Reformat Code action - existing spaces are converted into tabs. Immediately afterwards, the "Problematic whitespace" inspection starts complaining that the file uses tabs.

0
Comment actions Permalink

I don't know, either I'm doing something wrong or the settings are just straight up broken. I just tried disabling an inspection in Global layer, then I use Copy Settings To -> Team-Shared, select code style and inspections, and literally nothing happens. The inspection doesn't change. Only right-clicking on Team-Shared and using the Reset option worked, but that deleted the current sln.DotSettings file so I had to Copy Settings again to restore it. I'm confused.

0
Comment actions Permalink

I'm leaning towards broken... this is how some of my inspections are configured:

I have these inspections enabled in "This Computer" layer, but I specifically disabled them for the current project in both the "Team-Shared" and "Personal" layer. Yet the sln.DotSettings file shows this:

<s:String x:Key="/Default/CodeInspection/Highlighting/CodeIssueFilter/IssueTypesToHide/=_003CConfigurableSeverity_0020Id_003D_0022StringStartsWithIsCultureSpecific_0022_0020_002F_003E/@EntryIndexedValue">DoShow</s:String>

"DoShow"

And of course, I can see the inspection even though it's disabled:

Even manually changing the XML to DoHide does absolutely nothing.

I don't understand why this doesn't work, it's so frustrating.

0

Please sign in to leave a comment.