How to stop Rider automatically putting line spaces after if statements / method declarations ect.

how do I stop rider placing the curly bracket on the next line after a statement, for example:

I want to write

if (x){

}

but rider will auto correct this to 

if (x)

{

}

placing the open curly bracket on the next line to the if statement. Is there any way to turn this off as I find it incredibly infuriating.

1 comment
Comment actions Permalink

Hello, 

Please try to set File | Settings| Editor | Code Style | C# -> Braces Layout -> Other to At end of line (K&R style).

0

Please sign in to leave a comment.