Build profiles are not shown

Hi,

 

I changed the application path of a configuration. Since then, the profile is completely disappeared from the build profile dropdown list. How can I make it selectable again?

10 comments
Comment actions Permalink

Hi Tabaloa,

Could you please provide some screenshots? I'd like to see where exactly you changed application path of a configuration, and where in the UI you expect to see this configuration.

Thank you!

0
Comment actions Permalink

Hi,

 

I'm not allowed to share screenshots, but I can try to describe:
I mean the dropdown list (launch setting profiles) between the architecture dropdownlist and the "Run" button in the top toolbar, right side. Expected is, that two entries should be in the launch setting profile dropdownlist, but I only see one. When I open the dialog with "Edit configurations", I can verify that under ".NET Launch Settings Profile", there is only one profile instead of two. My launchSettings.json contains two profiles. However, clicking on that one profile under ".NET Launch Settings Profile" will show the details on the right side. There, under "Launch Profile" (3. from above) I see both my profiles. Seems like, my profiles just moved!

Within the same dialog, there is the Application URL (the text is greyed out but the Textfield itself is not readonly). 

 

However, the profiles feel a bit strange. If I open my launchSettings.json (located in projectName/Properties/launchSettings.json), it's a totally different launchSettings.json located at "C:\Users\myUsername\.nuget\packages\ros.platform.mvc\1.0.900\contentFiles\any\netcoreapp3.1\Properties\launchSettings.json".

I can see my real config when I open the dialog as above ("Edit configurations...")  and click on "Profile parameters are set by ...: open in editor". 

 

Hope I could explain it precisely enough.

0
Comment actions Permalink

Thanks a lot for the detailed explanation! It is totally understandable. There are only two things that I didn't get:

1. You say that you've changed Application URL just before the run configuration disappeared. Is that true? Did you change it via the run configuration dialog, or in the code editor?

2. You say that you try to open launchSettings.json located in Properties folder, but Rider opens the one from ros.platform.mvc package instead. I didn't get how exactly you try to open the file. Do you double click on it in the Solution Explorer?

Are you allowed to share your projectName/Properties/launchSettings.json file with me? You can delete all sensitive data from it if needed.

0
Comment actions Permalink

Glad I could explain myself understandable.

To answer your questions:

1. I changed the application url in the configuration dialog and closed it by hitting apply and then ok.

2. Right, I double click the launchSettings.json. 

I guess I can share that with you. The launchSettings.json is located in the "Properties" folder of the project.

{
"$schema": "http://json.schemastore.org/launchsettings.json",
"iisSettings": {
"windowsAuthentication": false,
"anonymousAuthentication": true,
"iisExpress": {
"applicationUrl": "http://localhost:50500",
"sslPort": 44313
}
},
"profiles": {
"Debug": {
"commandName": "Project",
"launchBrowser": false,
"environmentVariables": {
"ASPNETCORE_ENVIRONMENT": "Development"
},
"applicationUrl": "http://localhost:6000"
},
"Develop": {
"commandName": "Project",
"launchBrowser": true,
"launchUrl": "swagger",
"environmentVariables": {
"ASPNETCORE_ENVIRONMENT": "Development"
},
"applicationUrl": "http://localhost:6000"
},
"Test": {
"commandName": "Project",
"launchBrowser": true,
"launchUrl": "swagger",
"applicationUrl": "http://localhost:6000",
"environmentVariables": {
"ASPNETCORE_URLS": "http://*:6000",
"ASPNETCORE_ENVIRONMENT": "Development"
}
}
}
}

 

 

0
Comment actions Permalink

Hello, Tabaloa. First, a couple of questions:

  1. What version of Rider do you use?
  2. Could you please tell us names of the configurations that you can see in the run configuration selector?
  3. It is a bit unclear how many configurations do you expect to see. You said "Expected is, that two entries should be in the launch setting profile dropdownlist", whough the launchSettings.json file you've shared shows three profiles.

As a workaround, you may try the following:

  1. Right click the launchSettings.json file, and choose Generate Configurations: ideally, it should regenerate the configurations based on the file content.

    Sadly, Rider doesn't generate new configurations based on launchSettings.json changes as of now; I've filed an issue RIDER-60018 about that issue.
  2. In case it doesn't work, then you should be able to create your own new .NET Launch Settings Profile configuration in the run configuration menu, and set it up to use the profile from your version of launchSettings.json.

If I open my launchSettings.json (located in projectName/Properties/launchSettings.json), it's a totally different launchSettings.json located at "C:\Users\myUsername\.nuget\packages\ros.platform.mvc\1.0.900\contentFiles\any\netcoreapp3.1\Properties\launchSettings.json".

This is possible in case a NuGet package tries to provide a launchSettings.json file, though I don't think it will work well with Rider currently.

Within the same dialog, there is the Application URL (the text is greyed out but the Textfield itself is not readonly). 

This is very strange and is likely a bug (the edit made this way in a .NET Launch Settings Profile run configuration won't be applied to anywhere, anyway). I couldn't reproduce it on the current build of 2021.1, though.

0
Comment actions Permalink

Hi,

 

to answer your question:

  1. Im using 
    JetBrains Rider 2020.3.3
    Build #RD-203.7148.23, built on February 17, 2021
  2. Actually only the "Develop" is listed in the selector.
  3. Sorry, you are right! The config above is not 100% correct, copied it from the wrong project. Omit the "Develop" profile and you're good to go. I expect "Debug" and "Test" to be shown in the configuration selector, but I only see "Debug".

 

Thanks for your suggestions. I will try them out.

However, I've found out that if I open the "Debug" configuration, I can choose any of my profiles there. This means, I open the "Debug" configuration and choose "Test" as my profile, then it works fine.

0
Comment actions Permalink

Hello!

Unfortunately I have the same issue (Rider 2021.2). In one moment (I don't understand what had happened) Rider has stopped to recognize launchSettings.json file for one of the projects in solution. So when I try to edit configuration I see

Configuration generation by file doesn't work. The file is correct because Visual Studio works with with no problems/

0
Comment actions Permalink

Could you please share your launchSettings.json file and/or create a YouTrack issue (if you would like to share it privately instead of on a public forum)?

0
Comment actions Permalink
{
"iisSettings": {
"windowsAuthentication": true,
"anonymousAuthentication": true,
"iisExpress": {
"applicationUrl": "http://localhost:44327/",
"sslPort": 44378
}
},
"profiles": {
"IIS Express": {
"commandName": "IISExpress",
"environmentVariables": {
"ASPNETCORE_ENVIRONMENT": "Development"
}
},
"IdentityServer": {
"commandName": "Project",
"environmentVariables": {
"ASPNETCORE_ENVIRONMENT": "Development"
},
"applicationUrl": "http://localhost:44327/"
}
}
}
0
Comment actions Permalink

One crazy idea: could it be that the file contains BOM, saved in UTF-16, or something else?

Also, could you please share the file location and .csproj location relatively to each other?

0

Please sign in to leave a comment.