FN + Backspace to delete character after cursor has stopped working

Really simple one here, I used to be able to use this shortcut that exists across all of OSX, but it has stopped working on Rider. I have tried other apps and they're okay. And I have tried setting another action to this shortcut, but it doesn't look like the FN key can be used for shortcuts in Rider preferences. Has anyone seen this before?

3 comments
Comment actions Permalink

Hi Cfin!

Thanks for contacting us.

What are your versions of macOS and Rider? 

Could you please attach a screenshot of your keymap with `Delete` shortcuts visible? Thank you in advance! 

0
Comment actions Permalink

Did this get resolved? I have the same issue.

0
Comment actions Permalink

Hi Tim Woods1,

I have some questions about this issue:

1. Does this shortcut work in other editors? Does it delete characters as expected?

2. Could you share your macOS keyboard settings.

3. In Rider, only fn + backspaceне does not work or there are other not working shortcuts with Fn?

4. Which keymap do you use in Rider (Preferences | Keymap)?

 

K.R.

Sofia

 

0

Please sign in to leave a comment.