Upgrade made Jetbrains Rider unusable / very slow


Hey team,

Just upgraded to
JetBrains Rider 2021.1.4
Build #RD-211.7628.50, built on July 13, 2021

And now, any scripts with more than 4k lines of code are very slow, impossible to work with.
Also, using Unity 2021.1.15, Windows 10 Pro, but it was working great with the version prior to this one.
Any suggestions? Can I go back a version?
It becomes normal with no Highlight settings on, but then it is just like another notepad, LOL


Hello Alex,

Unfortunately, you have faced a known issue: RIDER-65270, as a workaround you can disable Show indentation guides in Preferences | Editor | General | Appearance. Please watch the issue for monitoring the progress and accept our apologies for the inconvinience.


Thank you, Olga.


I am still/again experiencing real slowness in Rider. A couple of month ago, I had the same issue and ended up, re-buidling my PC from scratch. After that, Rider worked at a good speed for about 3 month and now it is back to being really slow. 

I am using Build #RD-221.5787.36, built on June 1, 2022 at the moment. 

It is not one thing that is slow, it is everything. Starting Rider, debugging, building and running a project.

For example, I am running a SQL database query on startup. This query takes 11972ms on the production server. If I run the code in Rider, the same takes 45378ms. Before Rider got slow, it ran quicker on my dev machine.

Other than installing update on Windows 10 and Rider, nothing has changed on the PC and all other apps run fine.

If anyone has got any idea what to try (and I have tried everything that has been suggested in various forum posts), I would be happy for some help ;-)



Ralf Balzer, please open the issue on our tracker and attach the information that will help us with investigation, like logs and profiling data. Thank you in advance!


Thanks Olga. I have created an issue under RIDER-78883


Ralf Balzer did you find a resolution to your issue? My problem is exactly the same using latest version of rider. Getting into a debug session takes forever.. but event moving from one method to another is taking about 4-5 seconds every time too. Any advice would be appreciated. 


mac mcdell I have a Windows 11 PC with a PRIME X299-DELUXE Motherboard. ASUS released an update for the BIOS (3701). This came out, after I had opened this issue and I have not had any problems since installing this. Even though the rest of the PC was performing right, I think it had to do with this, as the speed issues went away, as soon as I had updated the BIOS. 


For me it was solved a long time ago, yes. Disabling indentation did solve for me, but after a few patches from them, it was not needed.

I did have problems again last month, but because my project was very big (and launched already), with some scripts having 10k+ lines (not really ideal). I did not contact support because I upgraded my PC (more RAM) and now it works without any problems (I'm using 32 GB RAM for this project). For any other projects, it does work good.


hmmm... mine just went to hell about 3 weeks ago.. Running microservices in isolated process. It was very fast but then just went to nearly impossible. Using windows 11 laptop with nvme / 32gb ram. The exact same solution run under Visual Studio is ~7 seconds to debug and +- 20 ms between methods... Using rider is > 45 seconds to enter debug mode and ~8 seconds for each method step. No longer usable. 


mac mcdell, you say you faced the issue while "using latest version of rider", but also say it happens for about 3 weeks, so it started even before 22.3 was released? For any version, we will be happy to investigate it further. For debug issue, please collect the logs with Debug trace and send it to us via tracker. Thank you in advance!


Olga. Was happening before i tried upgrading. There is already a ticket open. I've been waiting on a reply for a week or so now.


Please sign in to leave a comment.