Git Bash as Terminal

Answered

I've made some changes to my git-prompt.sh file to change colors and font styling (bold, italic, etc). However, the terminal in Rider isn't rendering the styling. Am I missing something with this?

8 comments
Comment actions Permalink

Hello Kevheber

Could you please check what do you have setup under Preferences | Tools | Terminal under "Shell path"? Is there a path to git bash?

0
Comment actions Permalink

Yes, my path points to bash. I've noticed that this isn't specific to Rider. PHPStorm has the same.

0
Comment actions Permalink

What is your OS? And how did you configure the OS shell to take colors from the git-prompt.sh script? Do you see the colors in the OS terminal if you use this bash terminal? What are your IDE terminal settings?

As I understand for this to work you first need to configure the git bash shell prompt to honor this file. See here how to configure the bash profile to source the git-prompt.sh script https://gist.github.com/eliotsykes/47516b877f5a4f7cd52f

0
Comment actions Permalink

I'm on Windows 10. To change the colors, I modified my git-prompt.sh file in C:\Program Files\Git\etc\profile.d location. 

My IDE settings are pretty simple:

I'll give your link a try and see what I can find.

0
Comment actions Permalink

This is still not working for me. Here's what my terminal looks like inside Rider:

Here's how it should look:

Notice the Italics on the second one, but not the first.

0
Comment actions Permalink

Kevheber

See if using the following string for the shell path makes any difference:

"C:\Program Files\git\usr\bin\bash.exe" --login -i
0
Comment actions Permalink

Arina Efremova

That sadly didn't do anything for me, sadly.

0
Comment actions Permalink

Kevheber

I created a problem report for this on our issue tracker: IDEA-274449. We will try to reproduce the problem.

Feel free to follow the issue to stay updated on the progress of the investigation.

See this article if you are not familiar with YouTrack.

0

Please sign in to leave a comment.