Strange error message after upgrading Rider to the latest version

After upgrading to Rider version 2021.2 (Build #RD-212.4746.113) I now get a "Cannot resolve symbol 'oninput'" error in a Razor page with

<textarea @bind-value="@what.ever" @bind-value:event="oninput" />.

Compiling and running the application is not a problem, but the error indications bubbling up the Explorer tree and in the breadcrumb and tab header are annoying.
Any way to get rid of the error message? I don't want to downgrade to the previous version because of the nifty features in 2021.2.

5 comments
Comment actions Permalink

Hi Roland,

Could you try clearing caches via `File | Invalidate Caches...`? Can this help? If no, can you check if this is an issue only for one certain solution/project or you get the same issue on any?

Can you please share a simple repro?

K.R.

Sofia

0
Comment actions Permalink

"File | Invalidate Caches" did not help.

I made a public repo from a standard Blazor Server template with only Index.razor modified.

The app compiles and runs just fine, but the editor does not like the @bind-value:event.

 

1
Comment actions Permalink

I've had the same issue. "File | Invalidate Caches" doesn't help.

1
Comment actions Permalink

Same... "File | Invalidate Caches" doesn't help.

0
Comment actions Permalink

Hi there,

I've filed an issue for this problem: https://youtrack.jetbrains.com/issue/RSRP-485604.
Please, follow it for further updates.

 

K.R.

Sofia

0

Please sign in to leave a comment.