Stop build solution/selected projects from outputting warnings

I was wondering if there was a way to stop Rider from outputting warnings when building solutions or projects.

The issue I have is that a solution I work on is quite large and has a lot of warnings (there are thousands), mainly because it is old and the company used to suppress select warnings up until a few years ago.

So building the solution Rider spends most of its time writing all of the warnings to the build output and it wastes time.

6 comments
Comment actions Permalink

Hello Caleb,

Try changing settings in Preferences | Build, Execution, Deployment | Toolset and Build | Write log to output or change verbosity of it. Please let me know if that helps.

0
Comment actions Permalink

Hi Olga,

I have tried disabling the Write log to output setting but it sill records all warnings in the Build tab in Rider slowing it down.

Here are y current build settings:

I turned solution wide analysis on (I usually have it off for this solution because it is so large) to get an accurate amount of warnings. There are 56,504 warnings in the solution. I feel this solution is an outlier because no one probably expected this many.

0
Comment actions Permalink

Hi Caleb,

Could you share a screenshot of the build tool window with the warnings you get after building solution/project?

 

K.R.

Sofia

0
Comment actions Permalink

Here is a small amount of warnings from two projects in the solution. This sample is pretty much what the rest of the warnings are though.

0
Comment actions Permalink

Hi,

Thank you for screenshots.

As a workaround, let's try to configure the following setting: Preferences | Build, Execution, Deployment | Toolset and Build | Presentation - > Showing build results after build completed = Only if errors received.

Can it work for you?

 

K.R.

Sofia

0
Comment actions Permalink

Yes, this does reduce the time it takes to build, which is good.

Thanks.

1

Please sign in to leave a comment.