Cannot retrieve debug connection: Debug mode is not supported for 'Docker-compose

Hello everyone,

I'm currently facing the issue that I can't debug into a running docker container anymore. Just 2-3 weeks ago, it worked perfectly.

I get the message which is written in the title "Cannot retrieve debug connection: Debug mode is not supported for 'Docker-compose". My rider version is 2020.3.3 at time time of receiving this error message. And the docker plugin version is bundled 212.5080.71. The installed version of docker desktop in windows is 3.3.1 (63152) with engine: 20.10.5, compose: 1.29.0 .

I  now tried with the newest version of rider (2021.2.1) and now when I try to enter the debug mode the docker container get built and I see the logs in the running docker container, but still, rider doesn't enter into the debug mode inside this container.

How can I resolve this problem?

I would be grateful for any help!

4 comments
Comment actions Permalink

@Jetbrainssupport Ive got the Same Problem would be nice to see if there is a solution for this.

3
Comment actions Permalink

I have the same problem, any help would be appreciated.

3
Comment actions Permalink

Ich habe das gleiche Problem. Der Debug Mode lässt sich nicht anhängen.

1
Comment actions Permalink

Hello,

Could you please do the following:

- navigate to Help -> Diagnostic Tools -> Special Files an Folder -> PLUGINS PreInstalled Directory and send us the folder rider-plugin-appender;

- reproduce the issue and send us the frontend.log;

You can attach it there or with a new issue on tracker, on tracker you can set us visibility of files so that only JB representatives could see it. Thank you in advance!

0

Please sign in to leave a comment.