How to completely disable typo and spelling support?

I have a deep desire to completely, absolutely, globally and forever disable typo and spelling functionality in Rider (and other IDEs like AppCode and GoLand). -for now and for all foreseeable and unforeseeable future.
- for my current project/solution and all future projects and solutions.

 

I have gone through all preferences in the preference pane, and unchecked each and every single box I could find, mentioning "typo", "spelling", "grammar", "dictionary" or similar. There are a few. Quite a few, actually.

This has taken a substantial amount of time.

Yet, when returning to my editor, I am still getting green underlines, with suggestions to fix typos in my passwords, class names, base64 encoded certificate files, and many other things.

 

I can totally see why typo and spelling support is useful. And I understand that many people value it.

But I have no words for how annoying this is when I have explicitly disabled it in every thinkable setting I could find.

 

Is there really a way to disable typo and spelling support?

I would really like to know.

10 comments
Comment actions Permalink

Hi Hans Olav Loftum

Could you please also try to disable ``File | Settings | Editor | Inspection Settings | Inspection Severity | Other Languages -> Proofreading -> Typo``?

Also, we have a feature request for a fast disable spellchecker: IDEA-123965. It is quite abandoned, but you can vote for it and leave your comments to bring some attention to it. 

Should you have any other questions, let us know. 

 

0
Comment actions Permalink

Hi!

That setting is disabled, along with all other typo settings in the preferences pane. But Rider does not seem to respect that.

I would really like to be able to remove the spellchecker/typochecker/proofreader alltogether - much like a plugin. Would that be possible (in a future version)?

0
Comment actions Permalink

Hi Hans Olav Loftum

Could you please add some samples/screenshots of the code where Rider still shows you typo errors? 

The issue I mentioned is about disabling all parts of the spellchecker at once. Spellchecker is not a plugin for now. Maybe it will change in the future.  

 

0
Comment actions Permalink

Sorry for the late response.
These are examples where Rider is not happy with properties and certificates:



0
Comment actions Permalink

I have somehow achieved to disable typo checking for identifiers.

But I cannot make Rider globally disable Proofreading/Typo for "other languages".
If I try to
- disable Inspection settings/Inspection Severity/Other languages/Proofreading/Typo 
- save to "This computer", "Solution HestTest" or "Solution HestTest team-shared"
- open the preference pane again
then Proofreading/Typo is checked again, and Rider continues to complain about typos in lots of files.



If I just hit Save (without the dropdown), the setting seems to be disabled for the current solution or project.

I notice that there are 2 "profiles" for "Other languages". One is stored in the IDE, the other in the project.
It doesn't seem to matter much which of them I choose. The behavior is the same.

But: If I choose the Default/IDE profile, this profile seems to be available for all solutions. So if I open a solution, and choose this profile, the Default/IDE-settings will apply.
However, I have to select this profile for all solutions, since all solutions seem to have its own "Project" profile. And all new solutions seem to get a new "Project" profile by default.

And: Every time I create a new solution, both Respeller and Proofreading/Typo are enabled again.

0
Comment actions Permalink

Whoops. After fiddling a bit more, it seems like the "Project" profile has disappeared from the dropdown.
I am not sure what I did to achieve that.



Anyway, when I create a new solution, the new solution gets a new "Project" profile.

0
Comment actions Permalink

Hi Hans Olav Loftum

Thank you for the details and the investigation. I've checked and there is a small confusing issue on our side. The settings for "Other languages" are directory-based and cannot be saved to `This computer` layer. But Respeller should be saved there to be applied for new projects. Sorry for the inconvenience. 

When you create a new project, settings for "Other languages" should be based on default. If not, you can try one more thing: go to `File | Settings for new project` and disable there everything about spellcheck. 

I hope this helps! 

0
Comment actions Permalink

No worries, and thank you for looking into this.

Concerning layered settings:
There are a couple of things that may be confusing for some.
One of them is stated on the link you provided.


...which also implies that some may find it difficult to see that there actually _are_ layers.

One other is: Are the layers (default, computer, team, project) all required by the IDE?
In other words: Does the user have to deal with team- and project-layers, even if all the user ever will be interested in is the computer-layer?

I can see the value of the top layers, but this might also feel unnecessary and over-engineered for some. It may also annoying that every new solution will implicitly get a project layer of settings, with some defaults (like respeller enabled) that the user has to reconfigure.

0
Comment actions Permalink

Anway, aside from the settings layers:
It would be very nice if spelling/typo-functionality could be disabled/removed entirely from the IDE - like removing a plugin.
This is a feature I will likely never (or very rarely) use, and I would rather spend my CPU cycles on other things, like compiler and code analysis.

If this could be done, it would make me very happy.

0
Comment actions Permalink

Hi Hans! 

>Does the user have to deal with team- and project-layers, even if all the user ever will be interested in is the computer-layer?

No, it is not necessary to do something manually for this. These layers are useful when you have several teams, projects, or computers and share settings between them. 

I hope the fast spellchecker enable/disable feature will be implemented once. 

Should you have any other questions, do not hesitate to ask. 

 

0

Please sign in to leave a comment.