Why is Reformat on Save restricted to Explicit Save?

I was looking forward to this feature but as it turns out it works only when you save explicitly. I almost never save explicitly since files get saved on exit or debug so my files don't get formatted. 

I really would like to see an option that reformats on any save so I can sure my files are formatted consistently. 

 

1 comment
Comment actions Permalink

I'm addicted to pressing Ctrl-Shift-S, especially with "unnecessary whitespace is an error" and "remove unnecessary whitespace on save" active.

0

Please sign in to leave a comment.