Unreal Engine source files are excluded from color coding

Hello, im trying to find what configuration i need to check to solve this problem.

Im using Rider for Unreal, all my game classes are perfectly colored and i can use the shortcuts to jump to a definition of a method or struct.

But when i open an engine class its not colored and i cant use the shorctus (Ctrl + click) to functions defenitions.

Its like rider is only caring about my game project classes and not about the engine classes.

My monster spawner class

Unreal engine Actor class

 

3 comments
Comment actions Permalink

Hello Demianlopez1,

Could you please share the screenshot of the entire IDE window with an Unreal Engine class open in the editor (Actor or any other class) and share the message in the error indicator located in the top right (see the example below)?

 

0
Comment actions Permalink

Hello, thanks for the response, here it is.

Says that is disabled for that project, how can i enable it?

0
Comment actions Permalink

Hello Demianlopez1,

 

Apologies for the extremely late reply.

Were you using ReSharper++ in the past by any chance? It is possible the ReSharper was configured to exclude the engine directory using the mask in "Projects to ignore", Rider used the preexisting settings (Rider and ReSharper can both use DotSettings files) and ignored the engine as well.

0

Please sign in to leave a comment.