Rider Console does not have console mode ENABLE_VIRTUAL_TERMINAL_PROCESSING

Answered

I am using both Visual Studio and Rider for the same C# sln. On Windows I am using both VS and Rider and on Linux just Rider. For logging we have extended .NET tracing using a ConsoleTraceListener. The listener outputs logging text to the console of the application. It provides the option to use ANSI color codes for coloring the console output dependent on the log level. That works just fine on Windows (Win 10+) and Linux (Ubuntu). It also works if you start the app from VS on Windows. However, if you start the app with Rider on Windows both the internal console at the bottom of Rider and the external console window (if configured in the start configuration) to not color the log output. Investigation shows the the console (both internal and external) does not have the console mode ENABLE_VIRTUAL_TERMINAL_PROCESSING. Once, I add this manually in the code of the ConsoleTraceListener it works. 

On Linux it always works with Rider as the console seems to have the correct setting there. 

Is there a way to modify the console modes for the console that is started by Rider?

Again: in VS it works on Windows as it seems to use the correct default setting of the console. 

2 comments
Comment actions Permalink

Hello! Unfortunately, it looks like you have faced a known issue. We would appreciate it if you would upvote it in order to bring increased awareness to the issue. Also please click to Watch it for monitoring the status. Please let me know if there is anything else I could help you with. 

0
Comment actions Permalink

Thanks I have added a comment to the issue with a workaround solution.

1

Please sign in to leave a comment.