Rider 2021.3.2 on Arch Linux Grey Box even with _JAVA_AWT_WM_NONREPARENTING=1

Answered

Hello everyone

Basically, as the title says. I have JetBrains Rider 2021.3.2 and I'm running Arch Linux.

In my `.zprofile` I have `export _JAVA_AWT_WM_NONREPARENTING=1` and I've rebooted my computer.

When I start JetBrains Rider, I get:

What am I missing?

5 comments
Comment actions Permalink

Please try the workarounds mentioned in this ticket (vmoptions, OpenJDK)

If they do not help, create a new YouTrack ticket with idea.log attached. 

Thanks. 

0
Comment actions Permalink

Thanks for the reply Konstantin Annikov

Is Java required before I can run Rider?

The system requirements here do not mention that Java is required.

0
Comment actions Permalink

Java is not required as it is bundled with Rider. Bundled runtime called "JBR" (JetBrains Runtime). But in this case, you need to replace JBR with OpenJDK (the runtime JBR based on) as a troubleshooting step. 

0
Comment actions Permalink

Thanks Konstantin Annikov, I just checked and I am using java-11-openjdk

 

I then went to my rider64.vmoptions and added -Dsun.java2d.uiScale.enabled=false to the bottom of the file.

I then started Rider again, but I'm still getting the same problem. What am I missing?

0
Comment actions Permalink

Please create a new YouTrack ticket with the logs folder compressed after reproducing the issue.

0

Please sign in to leave a comment.