Jetbrains Rider, how to disable text indenting within documentation comments (summary tags)?

In Jetbrains Rider 2021.3x, after executing Code Clean Up, text in documentation comments are being indented. How can this be disabled?

   /// <summary>
   ///    Why does Rider indent these comments? How can it be disabled?
   ///    Any idea of what settings!?
   /// </summary>
   public class Person{}

How to prevent indenting text in summary tags, so that remains like this:

   /// <summary>
   /// Why does Rider indent these comments? How can it be disabled?
   /// Any idea of what settings!?
   /// </summary>
   public class Person{}

 

https://stackoverflow.com/questions/71608178

 

1 comment
Comment actions Permalink

Hi Rakesh Patel

Thanks for contacting us. I wasn't able to reproduce the issue in Rider 2021.3.3 and Rider EAP. Could you please open File | Settings | Editor | Code Style | C# => Tabs, Indents, Alignment settings and check if there is any sing about autodetecting/overriding? 

Thanks! 

0

Please sign in to leave a comment.