Disabling all insertion of brackets, quotes, etc.

One of the biggest things that impacts my ability to use an editor is this insertion of characters to match previous characters. In Rider I think I have managed to disable all but one that I cannot for the life of me figure out (can we please have an option that just turns all of this off??).

In a razor page cshtml, I type in <input type  and it will bring up an autocomplete list. Once I press the = key it will insert two double quotes and place the cursor in the centre of them. 

Under typing assistance with HTML/CSS, I turned off "Add Quotes for attribute value on typing '=' and attribute completion" which would seem to describe this, but apparently not for cshtml files.

1 comment
Comment actions Permalink

Hello, as I can see the same issue was also opened on the tracker: RIDER-76109. It is assigned to the dedicated developer, please keep watching the progress on it there. Thank you for your feedback!

0

Please sign in to leave a comment.