Xcode installation missing

I'm trying to build the iOS target of a Xamarin Forms project on my mac with Rider, but it always tells me that he cannot found Xcode :-/

I've tried several configurations, but nothing leeds to the solution. The problems started when I upgraded my Mac to Monterey.

The Xcode path was set correctly with xcode-select and is correctly setted up in Rider settings.

xcode-select -p

-> /Applications/Xcode/Xcode1330.app/Contents/Developer

In Rider configured:

I've also tried to modifiy the mtouch --sdk arguments:

The console says:

/Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch --launchsim /Users/.../Projects/.../.../....iOS/bin/iPhoneSimulator/Debug/device-builds/ipad13.5-15.4/....iOS.app --device=:v2:udid=8552B306-2475-47AF-TB4C-DCA68E7340C6 -sdk 15.4 --argument=-monodevelop-port --argument=10001 --setenv=__XAMARIN_DEBUG_PORT__=10001 --sdkroot /Applications/Xcode.app/Contents/Developer
error MT0055: The Xcode path '/Applications/Xcode.app/Contents/Developer' does not exist.

I don't know why mtouch is using a non-configured path ... Also Rider does not use the arguments provided.

Creating a symlink 

ln -s /Applications/Xcode/Xcode1330.app /Applications/Xcode.app does not solve the problem.

For various reasons I need more Xcode installations for older iOS projects.



What Rider version are you using? It looks similar to the known issue when deployment failed due to XCode being installed in non-default location: RIDER-65418. The issue is resolved in the latest Rider EAP available now. Would you be willing to check it?


Hello Olga,

thanks for your reply. I'm using version 2021.3.4


Please sign in to leave a comment.