Noob doubt: Math not working on Rider

Hi everyone,

firt of all sorry if this question is dumb. I'm starting to learn about coding and I've decided to use Rider for my studies with Unity (from literally zero). I had some issues with configuration:

  • The Math.XXX is not working while creating a new script. I mean, all words are white and is like I can't access the library (?) which is making it work. Have tried to install the NuGet but there isn't install buttons on the toggle details panel.
  • It seems to work only if Visual Code Community is already installed on the computer so I guess that is some kind of pluging but since I'm really noob I can't figure out how to solve it.

Thank you in advance :)

3 comments
Comment actions Permalink

using System;

Have you declared a namespace?
For Math other than Mathf provided by UnityEngine, you must declare the System namespace.

2
Comment actions Permalink

Yes Isaac Toast I've tried to set System at the begining of the scrypt, but does not work even that way. Actually Mathf does not work either.

I've tried to add the "using System" line on Visual Studio and then reopened the script on Rider. That worked. Still confused on how to do it in a proper and direct way.

0
Comment actions Permalink

Hello Iyan, what Rider version are you using? Can you make sure Rider is connected to Unity editor? Can you share a screenshot of UI with the issue to make it a bit more clear? Thank you in advance!

0

Please sign in to leave a comment.