2022.1 Disable Unit Tests/Coverage Inlay Hint

How do I disable Unit Test/Coverage Inlay hints that say "1 Test OK", "2 Tests OK", etc.?

I have all inlay hints disabled yet these still appear. Right clicking them gives no option (the other inlay hints I could choose to disable from a right-click menu). I see no option for them in the Tests menu, the Unit Tests window, or the Unit Tests Coverage window. Also don't see anything in the dotCover settings or Unit Testing settings.

1 comment

Hello Dave,

Thank you for contacting Rider support.
There was a bug in Rider 2022.1, it was not possible to disable this exact inlay hint. Now it is fixed in the latest Rider 2022.1.1.

You can disable these inlay hints via `File | Settings | Editor | Code Vision | disable checkbox "Covering tests"`

Hope it helps. Should you have any other questions or difficulties, please let me know.

Have a great day!


Please sign in to leave a comment.