2022.1 Unit Test Coverage gets stuck for single file

As I write new files of tests, after a few, one new file will stop receiving coverage highlights (it claims the tests are uncovered even though they pass). If I close and reopen the file, it will stop getting the gutter coverage highlight column altogether (not even claiming they are uncovered). Other files are unaffected. The tests still show success/failure, but the coverage highlight says uncovered (this is not even tested code, this is the tests themselves which ran and passed).

If I rename the file, the problem goes away for that file, but if I rename it back, the problem comes back, so it must be an entry in some cache somewhere that becomes corrupt. Restarting Rider fixes it, but only until I write some more test files.

Starting to see that if I fiddle with it, that it starts to say that it can't find the tests. It can only not find them with the original file name. If I give it a new file name it can find the tests again. If I change it back it can't find them again, and the tests either disappear or get Inconclusive: Can't find test.

I can't say how to cause this besides writing a few new files worth of tests. There's nothing special about the filename or the tests besides it being a new file that was just written.

If I say "Create New Session" with these broken tests, I can get them to be "inconclusive not found", and the log file doesn't say much interesting besides a warning about "Instrumentation was requested, but wasn't made".

I tried always building the test project manually first. The new tests would appear in the unit test explorer and I ran them from there instead of the > arrows in the editor. But it still happened. It seems to always happen on about the third new test file, not sure why that would be. Has now done that consistently like four times in a row.

3 comments
Comment actions Permalink

I am also having this problem in Rider 2022.1.1.

0
Comment actions Permalink

I'm also having this same issue in Rider 2022.1.2

0
Comment actions Permalink

Please refer to the RIDER-78014

 

 

0

Please sign in to leave a comment.