Breakpoints Not Triggering UE4 C++


Okay, after a problem with Visual Studio, I decided to switch over to using Rider (as suggested by a user on the Unreal Engine Forums).

This works around that problem, but using Rider, breakpoints are not triggered, when they should be.

Below, are the breakpoints that have been set in my Player-character's class constructor:

They remain the same colour when the solution is running (loading into the UE4-editor).

Playing the game in the editor (via PIE), would not cause the breakpoints to trigger, even though this is the class used for the Player-character (an instance of which, is spawned when play starts on the map/level).

Rider is loading the UE4-editor, with the DebugGame Editor | Win64 solution configuration. The version of Jetbrains Rider that is being used is 2022.1.*

Please let me know how I can resolve this issue. If there are any further details that you would require to help with this, let me know about that too and I will be happy to provide them.



Would you mind ensuring you start the project via the `Debug` button? It is right next to `Run`(triangle) button and looks like bug.


Thanks for the suggestion Dmitry.

When I have Rider try to have the project loaded into the editor via the 'Debug' button it builds correctly and tries to load into the editor...but locks-up Rider and then the rest of my system. 

This leads to me having to press and hold down the power button on my computer, for a full system shutdown, followed by me pressing it after this, to have the system start-up again.

I am not sure why this is the case, please let me know what could be causing this/additional details you will need to help me resolve this issue.

Thanks in advance.



We are sorry to hear that you encounter such an issue.
It is rare case and such a problem might be caused by antivirus. Would you mind trying to add the game project, engine and Rider folders to the list of trusted locations in your antivirus? You might also find this article useful.

Hope it helps, but if it doesn't, we would appreciate it if you could share the Rider logs in the following way:
When you encounter the same issue again and restart your machine, please archive the `%LOCALAPPDATA%\JetBrains\Rider{version}\log` folder, upload it to the [Upload Service]( and let me know the Upload ID.

I will be waiting for your response.


Thanks again for your suggestions Dmitry, I will have updates posted in this comment (editing it appropriately).

So far, I have tried having the rules on my anti-virus (Norton 360) changed, to allow access for UE4, Rider and my project files.

After this, I have had Norton's Auto-Protect and Smart Firewall disabled. I tried having the project load with these settings, but my computer locked up again. I will try having another piece of 'protection' software disabled on my computer and I will let you know how that goes.

EDIT: That other piece of 'protection' software is SpyHunter 5. After having this disabled, Rider was able to have the solution load into the UE4 Editor just fine. SpyHunter is quite a 'powerful' piece of anti-malware/anti-spyware software, so it might have caused issues for Rider (or even Visual Studio).


Thanks for your help though Dmitry, that resolves my problem :).


I am happy that I was able to help you. 
Should you have any other questions or difficulties in the future, do not hesitate to contact support.

Have a great day!


Please sign in to leave a comment.