Cannot set breakpoint, ue 5.0.1, rider 2022.1


when I compile  code, open ue5 and attach to process, no breakpoint can be set (na matter if this is in plugin or game):

"The breakpoint will not currently be hit. No executable code is associated with this line".
For some reasons DLL files ale not being loaded. But when i Run the project via 'debug' button, then breakpoints do hit.

How can I fix this? I think it worked in 2022.1 with ue 4.27.


cheers, Dawid


Same for me. Rider absolutely useless for UE5 development.


For me it doesn't work still, every time I want to debug I need to close ue, and start it once again by pushing Debug in Rider


Hello Dawid Buj and SAntoniuk,

Could you try compiling (CTRL+ALT+F11 assuming you are using Live Coding) the project once after attaching to the running UE instance? What happens to breakpoints - are they still inactive?


Bumping this as it is a real issue, I'm encountering it too.
I tried your suggestion with live coding enabled, I get the live coding to successfully complete by my breakpoints stay in this weird "cannot be hit" mode :(


Hello Dtaralla,

Would you mind reproducing this issue with additional trace scenarios enabled and sending us the logs? Please:

  • Open your project in Rider
  • Under Help -> Diagnostic Tools -> Choose Trace Scenario, select Debugger
  • Reproduce the issue (Attach to process, ensure that the breakpoints are inactive)
  • Use Help -> Report a Bug and agree to attach your logs
  • Disable Debugger tracing scenario

Please put a link to this thread in the issue description or leave a comment after creating an issue. Let me know if you have any questions about this process or if you are not comfortable sharing the logs with us.



Hi Dawid Buj,

We have found a solution. This is a limitation of Windows debuggers, I wrote about the solution in the ticket.



I tried the solution. Still can't debug UE5 Engine code. Is there anything else that might be wrong?


Hello Van. F,

Most probably the issue you encountered has a different root-cause. I responded to the email you sent us. Please find the response on your email.

Have a nice day!


Hi, hitting the same issue and this is a critical feature I'm missing.

I tried all the solutions I could find posted online so far:

  • moving project / engine / rider to same drive
  • testing all the start configuration (i.e. development/debug etc)
  • attaching debugger to process manually
  • setting the reg key mentioned in the ticket details to 5000

Nothing helped so far. 

Is there any news on this or anything else that would serve as a workaround?


Thanks  in advance



Hello Cores25 ,

We are sorry to hear that you encountered such an issue.

Would you mind sharing additional details as described below?

  • What is your OS?
  • What Engine version are you using (for example, 5.1 from Epic Games launcher or 5.3 built from sources on GitHub)?
  • Do breakpoints work at all? Or in both cases (when you set it in game project or engine code) it doesn't work?
  • Enable the Debugger trace scenario via Help | Diagnostic Tools | Choose Trace Scenarios;
  • Reproduce the issue and collect logs via Help | Collect Logs;
  • Disable the trace scenario enabled;
  • Upload the generated archive to the Upload service and let me know the upload ID;
  • Does debugging work outside Rider (in other IDE)?

Meanwhile, you may try the following workaround:

  • Export IDE settings via File | Manage IDE Settings | Export settings;
  • Close Rider;
  • Clean the Configuration and Plugins directories;
  • Launch Rider and restore default settings via Shift+Shift | type and select “Restore Default Settings” action;
  • Restart Rider;
  • Import IDE settings via File | Manage IDE Settings | Import settings;
  • Verify if that helps;

Have a nice day!


From what I can tell, it looks when switching engines, rider doesnt get the message. I confirmed this after I switched engine's, launched rider into the project, and if I look at the location of the files for the Engine, rider will still be pointing to the old Engine.

The only way to fix this, I think, is to delete the idea folder. Not %100 sure, cause I nuked the old Engine at the same time.


Hello Van,

Thank you for the information shared. Would you mind writing hypothetical steps to reproduce the issue and share the following information?

  • Are you on Windows?
  • Do you open a project via .sln or .uproject file?
  • What engine from and to you were upgrading? (Is it installed from Epig Games launcher?)
  • How exactly do you switch an engine version for a project?

Thank you in advance and have a nice day!

  • Yes, Windows 11
  • .uproject, there is no .sln file
  • Unreal 5.2 Source built to Unreal 5.2 in the Launcher
  • Right click on .uproject and “switch unreal engine version…”

Reproducing the issue is pretty easy:

  • shut down Unreal and close IDE
  • Right click on .uproject and “switch unreal engine version…” from source built engine to the epic launcher version
  • when its complete, reopen the IDE.
  • The engine files will still be pointing to the source built version

It took me a while to realize it never switched over. Theres no visual indicator. You have to inspect the engine files to notice.


Hello Van,

Apologies for keeping you so long without an answer. 

Thank you for the details shared. The behavior of reopening previously opened editor tabs is a designed behavior. We didn't expect it might cause such an issue after retargeting a project to a different the engine version. Indeed, there is a place for improvement. I was able to reproduce this issue and reported it to our tracker:

We would appreciate it if you could upvote these issues to demonstrate your interest.

Should you have any other questions or difficulties, please tell me.

Have a nice day!


Please sign in to leave a comment.