Cannot set breakpoint, ue 5.0.1, rider 2022.1


when I compile  code, open ue5 and attach to process, no breakpoint can be set (na matter if this is in plugin or game):

"The breakpoint will not currently be hit. No executable code is associated with this line".
For some reasons DLL files ale not being loaded. But when i Run the project via 'debug' button, then breakpoints do hit.

How can I fix this? I think it worked in 2022.1 with ue 4.27.


cheers, Dawid

Comment actions Permalink

Same for me. Rider absolutely useless for UE5 development.

Comment actions Permalink

For me it doesn't work still, every time I want to debug I need to close ue, and start it once again by pushing Debug in Rider

Comment actions Permalink

Hello Dawid Buj and SAntoniuk,

Could you try compiling (CTRL+ALT+F11 assuming you are using Live Coding) the project once after attaching to the running UE instance? What happens to breakpoints - are they still inactive?

Comment actions Permalink

Bumping this as it is a real issue, I'm encountering it too.
I tried your suggestion with live coding enabled, I get the live coding to successfully complete by my breakpoints stay in this weird "cannot be hit" mode :(

Comment actions Permalink

Hello Dtaralla,

Would you mind reproducing this issue with additional trace scenarios enabled and sending us the logs? Please:

  • Open your project in Rider
  • Under Help -> Diagnostic Tools -> Choose Trace Scenario, select Debugger
  • Reproduce the issue (Attach to process, ensure that the breakpoints are inactive)
  • Use Help -> Report a Bug and agree to attach your logs
  • Disable Debugger tracing scenario

Please put a link to this thread in the issue description or leave a comment after creating an issue. Let me know if you have any questions about this process or if you are not comfortable sharing the logs with us.



Please sign in to leave a comment.