Rider cannot see all Environmental Variables

Hi 

 

I've added some environmental variables to system level - they're not visible in Rider - (I was resetting rider and whole machine/OS)

The list in Rider is shorter than the one in system settings.

I know I can add those variables in upper window - but why Rider doesn't get system level vars? 

And I want to stress again that IDE was restarted and local system was also restarted. 

 

Thanks Michal

4 comments
Comment actions Permalink

Hi Michal Szilder

Thanks for contacting us. If you run Rider via Toolbox, please restart also Toolbox after setting a new variable. I double-checked on the latest Rider 2022.1.1 version and it should work. Please let me know if you have another experience. 

Thanks! 

0
Comment actions Permalink

When I start Rider 2022.2.1 (not via Toolbox) it does not have access to many environment variables defined in either .bashrc or .zshrc.

0
Comment actions Permalink

Ok I wasn't using toolbox at all. Does it change anything when started using toolbox or toolbox is uninstalled?

0
Comment actions Permalink

Hi Kris! 

As I can see, you've already contacted us privately. Our team will prepare the answer soon. 

Michal Szilder, if you have Toolbox, you need to restart both Rider and Toolbox to pick up new environment variables. If you don't have it installed, only IDE should be restarted. If there is still an issue, could you please clarify how you add new environment variables? 

Thanks! 

0

Please sign in to leave a comment.