Rider 2022.2 - Merge All Project Windows not working (mac os 11)

Answered

I'm running Rider 2022.2 on a mac running MacOS v11.6. I was really excited to see the new feature around tabulating multiple project views finally get released, but it's not appearing in the Window dropdown menu. I've invalidated my caches, restarted my machine, even tried adding a key binding to it (I can see the feature in the key bind menu but the key bind fails to do anything).

Is there anything else I can do to get this feature working?

11 comments
Comment actions Permalink

Likewise, was excited for this. Not in the Window menu, and adding keybinding does nothing. MacOS v12.4, Rider 2022.2

0
Comment actions Permalink

Hello.

Could you please ensure, the Mac setting `Apple | System preferences | General | Prefer tabs` is set to `never` or `in full screen`?
Please let me know if it doesn't help. Have a nice day!

0
Comment actions Permalink

I changed the setting you referenced to never and also updated to Monterey v12.5 but still the menu option does not appear 

0
Comment actions Permalink

Restoring to default settings via the launcher's Configure -> Restore Default Settings fixed the issue.

0
Comment actions Permalink

Hello,
I am happy to hear that the solution was found.
Have a nice day!

0
Comment actions Permalink

Is there a solution that does not require one to destroy all their customized IDE settings in order to access this feature?

0
Comment actions Permalink

Hello Dave,

Thank you for your question. Have you tried setting the `Apple | System preferences | General | Prefer tabs` to `never` or `in full screen`?
If it doesn't help, would you mind sharing your IDE settings with us, so we can investigate the issue and suggest a proper solution?

  • Export Rider settings (via `File | Manage IDE Settings | Export Settings`) when the issue persists;
  • Upload the generated archive to the Upload service and let me know the Upload ID.

Thank you in advance and have a nice day!

0
Comment actions Permalink

Hi Dmitry,

I did try setting the Apple preference per your earlier suggestion but it had no effect.

I've uploaded my settings. Upload id: 2022_09_06_GeFVhqENJ5xgXBHDgfWVSn (file: settings.zip)

Thanks for your assistance!

0
Comment actions Permalink

Hello Dave,

Thank you for the details shared.
Would you mind trying the following steps and letting me know if it helps?

  • in Rider press `Shift+Shift`;
  • type `Registry`;
  • in the window opened find the `ide.mac.bigsur.window.with.tabs.enabled` flag (you can start typing it in this window to find it quicker). It is disabled in your settings;
  • enable this flag;
2
Comment actions Permalink

Hi Dmitry,

That worked! Awesome! This is a fantastic feature.

Thanks for your help!

0
Comment actions Permalink

Hello Dave,

I am glad to hear that I was able to help.
Should you have any other questions or difficulties in the future, do not hesitate to contact support.

Have a nice day!

0

Please sign in to leave a comment.