MSBuild no longer work after Snap update

Hello

I have been an happy user of Rider on Linux for a few years. I installed Rider and .NET using Snap (which is officially supported I think). Today Snap updated Rider and now all my project load with errors about MSBuild not working and I don't have any code analysis anymore.

Here is the error message Rider is giving me:

MSBuild process was started from '/snap/dotnet-sdk/current/sdk/6.0.302/MSBuild.dll', but IDE failed to connect to it. It means MSBuild crashed or froze during startup.

Here is the log

Microsoft (R) Build Engine version 17.2.0+41abc5629 for .NET
Copyright (C) Microsoft Corporation. All rights reserved.
Build started 8/4/2022 9:21:21 PM.
Project "/tmp/JetBrainsPerUserTemp-1000-1/Fakufez.proj" on node 1 (default targets).
ControllerTarget:
  Run controller from /var/lib/snapd/snap/rider/307/lib/ReSharperHost/JetBrains.Platform.MsBuildTask.v15.dll
Done Building Project "/tmp/JetBrainsPerUserTemp-1000-1/Fakufez.proj" (default targets).
Build succeeded.
    0 Warning(s)
    0 Error(s)
Time Elapsed 00:00:00.36

If I try to execute /snap/dotnet-sdk/current/sdk/6.0.302/MSBuild.dll in the terminal I get Permission denied because MSBuild.dll doesn't have execution permission. I don't know if this is normal or not.

I tried reverting to previous Rider version but Snap won't allow it. I tried completely uninstall and reinstall .NET and Rider but the result is the same.

I CAN NO LONGER WORK! Please help.

 

1 comment
Comment actions Permalink

Hi

I had the same problem but luckily a friend helped me.

It is basically this solution: https://stackoverflow.com/a/70138568/18110284 

To fix this issue I had to install the package with apt instead of snap. Make sure to use 6.0 instead of 5.0

0

Please sign in to leave a comment.